RIP实验----实验总结

CCNP 专栏收录该内容
17 篇文章 0 订阅

实验拓扑:

1.R1为ISP,其上只能配置IP地址,不能再进行其他配置!!

2.R7的环回地址172.16.1.0/24

R8的环回地址172.16.2.0/24

R7-R8之间的地址是78.1.1.0/24

剩余所有网络地址使用192.168.1.0/24

3.R2-R5的环回通过R3访问

4.加快协议收敛速度,保证更新安全,尽量减少路由条目数量

5.R2-R8设备均可访问R1环回

6.R1 telnet R2实际登录到R8

 

重要知识分析:

  1. R2-R5的环回需要通过R3访问!那就说明要走上面那条路!那就要把下面那条路的度量值加大!!
  2. 尽量减少路由条目,需要在各个需要汇总的路由的各个接口做手工汇总!!
  3. 在内网要所有路由器需要缺省指向边界路由器时,不要再手配缺省了,在边界路由器上直接向内网下放缺省就行了
  4. V1和V2兼容问题,在R7进接口f0/0配置ip rip send version 1,ip rip receive version 2;在R6进接口f1/0配置ip rip send version 2 ,ip rip receive version 1 即可!!

三个易忘点:

远程登录:username xixi privilege 15 secret haha

                   line vty 0 4

                   login local

端口映射:ip nat inside source static tcp 172.16.2.1 23        192.168.1.14 23

                                                                  映射到的地方        Telnet的地方

连续子网:如果你只是宣告了一个第二地址,没宣告78.1.1.0那个网段,那么你ping不了192.168.1.0中的所有主机,除非用扩展ping,所以你要将78.1.1.0那个网段也宣告出去才得行

Show run!!

 

ISP:

!

hostname R1

!        

interface Loopback0

 ip address 192.168.1.193 255.255.255.224

!         

interface FastEthernet0/0

 ip address 192.168.1.13 255.255.255.252

 duplex auto

 speed auto

!

 

边界路由器:

!

hostname R2       

!         

username xixi privilege 15 secret 5 $1$KqE0$Jek6dL.CH010Oj99Vi14N1

!                

interface Loopback0

 ip address 192.168.1.129 255.255.255.240

 ip rip advertise 15

!         

interface Loopback1

 ip address 192.168.1.145 255.255.255.240

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.14 255.255.255.252

 ip nat outside

 ip rip advertise 15

 ip virtual-reassembly

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 192.168.1.21 255.255.255.252

 ip nat inside

 ip rip advertise 15

 ip virtual-reassembly

 ip summary-address rip 192.168.1.128 255.255.255.224

 duplex auto

 speed auto

!         

interface FastEthernet1/0

 ip address 192.168.1.17 255.255.255.252

 ip nat inside

 ip rip advertise 15

 ip virtual-reassembly

 ip summary-address rip 192.168.1.128 255.255.255.224

 duplex auto

 speed auto

!         

router rip

 version 2

 timers basic 15 90 90 120

 offset-list 1 in 2 FastEthernet1/0

 network 192.168.1.0

 default-information originate

 no auto-summary

!         

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.1.13

!         

!         

no ip http server

no ip http secure-server

ip nat inside source list 2 interface FastEthernet0/0 overload

ip nat inside source static tcp 172.16.2.1 23 192.168.1.14 23 extendable

!         

access-list 1 permit 192.168.1.160

access-list 2 permit any

!         

R3:

!

hostname R3

!      

interface Loopback0

 ip address 192.168.1.65 255.255.255.240

 ip rip advertise 15

!         

interface Loopback1

 ip address 192.168.1.81 255.255.255.240

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.22 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.64 255.255.255.224

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 192.168.1.1 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.64 255.255.255.224

 duplex auto

 speed auto

!         

router rip

 version 2

 timers basic 15 90 90 120

 network 192.168.1.0

 no auto-summary

!         

R4:

!

hostname R4

!       

interface Loopback0

 ip address 192.168.1.33 255.255.255.240

 ip rip advertise 15

!         

interface Loopback1

 ip address 192.168.1.49 255.255.255.240

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.2 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.32 255.255.255.224

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 192.168.1.5 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.64 255.255.255.224

 duplex auto

 speed auto

!         

router rip

 version 2

 timers basic 15 90 90 120

 network 192.168.1.0

 no auto-summary

!      

R5:

hostname R5    

!         

interface Loopback0

 ip address 192.168.1.161 255.255.255.240

 ip rip advertise 15

!         

interface Loopback1

 ip address 192.168.1.177 255.255.255.240

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.9 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.160 255.255.255.224

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 192.168.1.6 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.160 255.255.255.224

 duplex auto

 speed auto

!         

router rip

 version 2

 timers basic 15 90 90 120

 network 192.168.1.0

 no auto-summary

!       

R6:

!

hostname R6

!       

interface Loopback0

 ip address 192.168.1.113 255.255.255.240

 ip rip advertise 15

!         

interface Loopback1

 ip address 192.168.1.97 255.255.255.240

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.10 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.96 255.255.255.224

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 192.168.1.18 255.255.255.252

 ip rip advertise 15

 ip summary-address rip 192.168.1.96 255.255.255.224

 duplex auto

 speed auto   

!         

interface FastEthernet1/0

 ip address 192.168.1.29 255.255.255.252

 ip rip advertise 15

 ip rip send version 1 2

 ip summary-address rip 192.168.1.96 255.255.255.224

 duplex auto

 speed auto

!         

router rip

 version 2

 timers basic 15 90 90 120

 network 192.168.1.0

 no auto-summary

!      

R7:

hostname R7

!    

interface Loopback0

 ip address 172.16.1.1 255.255.255.0

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 192.168.1.30 255.255.255.252

 ip rip advertise 15

 ip rip send version 1 2

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 ip address 172.16.3.1 255.255.255.0 secondary

 ip address 78.1.1.1 255.255.255.0

 ip rip advertise 15

 duplex auto

 speed auto

!         

router rip

 version 1

 timers basic 15 90 90 120

 network 172.16.0.0

 network 192.168.1.0

 no auto-summary

!      

R8:

!

hostname R8

!       

username xixi privilege 15 secret 5 $1$lCBD$rI/EV2jNqHj9NeMopQpDO1

!                

interface Loopback0

 ip address 172.16.2.1 255.255.255.0

 ip rip advertise 15

!         

interface FastEthernet0/0

 ip address 172.16.3.2 255.255.255.0 secondary

 ip address 78.1.1.2 255.255.255.0

 ip rip advertise 15

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!         

router rip

 version 1

 timers basic 15 90 90 120

 network 172.16.0.0

network 78.1.1.0

 no auto-summary

!              

    总结:

1.对 RIPv1 和 RIPv2的兼容了解 欠佳!!

2.对RIP的干涉选路的设置位置了解欠佳

3.下放缺省只用在边界路由器进rip直接向内网下放缺省即可!不要再手配缺省了!!

 

第二次学习总结:

1.未想到ping用的是端口ip去ping的,回包也是用端口ip作为目标ip的,所以未宣告78.1.1.0网段,导致卡死在这里,好在后面自己想到了!!

 

 

  • 5
    点赞
  • 1
    评论
  • 8
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 书香水墨 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值